Skip to content

Image: cyber.gc.ca · rights & removal

Executive Summary

The Canadian Centre for Cyber Security has issued an alert regarding critical vulnerabilities in PHP, specifically Use After Free vulnerabilities affecting multiple versions of the language, known as "php2shell." These vulnerabilities are tracked as CVE-2026-109618 and CVE-2026-109619. Successful exploitation could allow an unauthenticated threat actor to execute arbitrary code on affected systems, posing heightened risk to internet-facing PHP servers and applications.
The PHP Security Team released security updates on October 21, 2026, addressing these initial vulnerabilities. A subsequent update on October 23, 2026, introduced a second vulnerability, CVE-2026-115560, which requires an uncommon configuration of PHP to be successfully exploited; this vulnerability is not covered by the previous updates. For CVE-2026-115560, the recommended mitigation is disabling the session upload progress feature: session.uploadprogress.enabled=0 until a formal security update is released.
The alert strongly recommends immediate action for organizations to upgrade affected PHP installations to fixed versions, specifying target fixes for PHP 8.5.x (8.5.12), PHP 8.4.x (8.4.27), PHP 8.3.x (8.3.36), and PHP 8.2.x (8.2.35). Additional recommendations include prioritizing internet-facing systems, identifying vulnerable third-party components, isolating applications if remediation is delayed, and continuous log monitoring for suspicious activity.

Facts Only

* Vulnerabilities CVE-2026-109618 and CVE-2026-109619 are Use After Free vulnerabilities (CWE-416) affecting multiple PHP versions, known as "php2shell."
* Successful exploitation allows an unauthenticated threat actor to execute arbitrary code on an affected system.
* Internet-facing PHP servers and applications are identified as being at heightened risk.
* Security updates addressing the initial vulnerabilities were released on October 21, 2026.
* A second vulnerability, CVE-2026-115560, was published on October 23, 2026, and is not addressed by the previous updates.
* Exploitation of CVE-2026-115560 requires an uncommon combination of PHP configuration and application behavior.
* The recommended mitigation for CVE-2026-115560 is disabling session upload progress: session.uploadprogress.enabled=0.
* Fixed versions are recommended: PHP 8.5.x prior to 8.5.12, PHP 8.4.x prior to 8.4.27, PHP 8.3.x prior to 8.3.36, and PHP 8.2.x prior to 8.2.35.
* Versions 8.1 and older no longer receive updates from the PHP project.
* Organizations must update affected installations immediately and prioritize internet-facing systems.

Full Take

The narrative functions by establishing a clear, escalating threat profile centered on widely deployed software, leveraging urgency to drive immediate operational change. The initial notification focuses on well-known Remote Code Execution flaws ("php2shell"), which immediately triggers fear appeal against systems exposed to the public internet, capitalizing on the perceived ease of unauthenticated exploitation. The subsequent introduction of a second, more complex vulnerability (CVE-2026-115560) shifts the focus from broad patching to nuanced configuration dependency, demanding deeper security diligence.
The pattern relies on an appeal to authority—the Cyber Centre—to enforce specific technical remediation steps (upgrades and configuration changes). This structure effectively creates a mandate for immediate action, framed as necessary defensive behavior rather than a speculative risk assessment. The implication is that inaction carries significant, unmitigated exposure. A critical layer of analysis involves recognizing the tension between rapid deployment mandates and the reality of complex system environments. When an organization must choose between immediate operational continuity and comprehensive security hardening across heterogeneous systems, the instruction to isolate internet-facing applications until a fix is applied touches upon resource allocation and organizational friction.
The context suggests that infrastructure—specifically widely used components like PHP—is not merely a technical dependency but a critical vector for systemic risk affecting countless applications. The pattern of identifying vulnerabilities in ubiquitous software suggests a broader systemic issue regarding the maintenance and patching landscape across global digital systems. What is the true cost when immediate remediation conflicts with operational realities, and how does an organization manage the inherent uncertainty when mitigation steps depend on specific runtime behaviors rather than universal patches?

From the original · Canadian Centre for Cyber Security Alerts

Number: AL26-026 Date: October 21, 2026 Updated: October 23, 2026 Audience This Alert is intended for IT professionals and managers. Purpose An Alert is used to raise awareness of a recently identified cyber threat that may impact cyber information assets, and to provide additional detection and mitigation advice to recipients.
Read the full story at cyber.gc.ca
AL26-026 - Critical vulnerabilities impacting PHP - CVE-2026 | Huntaegis